首页 > 分享 > 易语言5.3版本的bug
2015
01-06

易语言5.3版本的bug

这个bug在以前版本就有的了,只是一直没太关注而已

刚才需要用到时间事件功能才发现,易语言里面的1秒=现实的3秒左右,太扯了。没办法,程序没修复之前,还是要用的啊

bug测试:

.版本 2

.程序集 窗口程序集_启动窗口

.子程序 _时钟1_周期事件

时钟1.时钟周期 = 时钟1.时钟周期 + 1000
编辑框1.内容 = 到文本 (时钟1.时钟周期)

这里的输出结果1秒等于电脑的3秒了

我自己临时解决方法,从系统时间来进行计时,然后提取秒数来给我做倒计时,代码如下

.版本 2

程序运行时间 = 程序运行时间 + 1
天 = 系统运行时间 \ 3600 \ 24
时 = 程序运行时间 \ 3600
分 = (程序运行时间 - 时 × 3600) \ 60
秒 = 程序运行时间 - 时 × 3600 - 分 × 60
倒计时标签.标题 = 到文本 (天) + “天” + 到文本 (时) + “小时” + 到文本 (分) + “分钟” + 到文本 (秒) + “秒”

这样就能获得系统正确的时间了。可以暂时替代时间事件里面的【时钟1.时钟周期 = 时钟1.时钟周期 + 1000】这个效果

最后编辑:
作者:彬子
彬子
这个作者貌似有点懒,什么都没有留下。

留下一个回复